[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

Modifizierte Firmware, sowie Erweiterungen wie z.B. Telnet, ftp oder SSH einbauen. Das Forum für echte Linux-Tüftler und solche, die es werden wollen.
Nachricht
Autor
MikeBatt
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 22. Mai 2018 17:29
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#76 Beitrag von MikeBatt » 20. Dez 2018 16:11

Also nach nun mehr 200 Geräten hab ich den Dreh raus. Es ist absolut easy wenn man einmal weiß wie es geht. Versuche es kurz zu erklären wie ich es mache, mit Windoof

1. per FTP auf die Box , dann frage ich ab welche Partition aktiv ist.
2. egal ob da nun steht enviroment not set oder welche Partition, ich setze immer auf Null
3. ich logge mich per ncftp auf die Box, dabei wichtig vorher im windows auf Bye zu gehen
4. ich hab mir 2 Verzeichnisse mit den nötigen Files gemacht

quote MEDIA FLSH
binary
passive on


lcd c:\6490\ARM


put -z filesystem.image mtd0
put -z kernel.image mtd1


lcd c:\6490\x86


put -z filesystem.image mtd6
put -z kernel.image mtd7


Das sind dann die einzelnen Schritte die ich mache im NCftp. Danach wieder raus , die Box neu starten und nach 1 Minute wieder ausschalten. Danach nochmal per ftp rein, branding auf AVM setzen und wenn vorher die Partition Null war einfach neu starten , sollte sie vorher 1 gewesen sein, wieder auf 1


Ganz sicher ist das nicht der beste und kürzeste Weg, aber in jedem Fall ist er effektiv, denn ich brauche 5 Minuten pro Gerät und es klappt wunderbar , ich möchte mite meiner Methode sicher nicht @Peter Pawn schlecht machen, denn ohne Ihn wäre ich niemals zu dem gekommen was ich jetzt habe

Hinzugefügt nach 9 Minuten 21 Sekunden:
Niemals vor dem flashen das Branding verändern das mögen die Kisten nicht. Nach allen Problemen die ich am Anfang hatte , bin ich froh das ich aus allen Werken für mich das gemacht habe was geht

Benutzeravatar
qwertz-asdfgh
Globaler Moderator
Globaler Moderator
Beiträge: 261
Registriert: 18. Okt 2017 21:47
Wohnort: Südliches T. d. A.
Hat sich bedankt: 4 Mal
Danksagung erhalten: 50 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#77 Beitrag von qwertz-asdfgh » 20. Dez 2018 18:45

Darf man mal fragen warum du überhaupt die Variable "linux_fs_start" anfasst? Wenn du nachher sowieso wieder das zuletzt aktive Partitionsset nutzt und auch in dieses die Firmware hoch lädst kannst du den Wert dieser Variable auch gleich unberührt lassen bzw. einfach ignorieren.

MikeBatt hat geschrieben:
20. Dez 2018 16:21
Niemals vor dem flashen das Branding verändern das mögen die Kisten nicht.
Nur wenn man die Box zwischendurch durchstarten lässt kann das u.U. zum Problem werden. Ansonsten spielt es keine Rolle ob man es vorher oder nachher macht.

MikeBatt
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 22. Mai 2018 17:29
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#78 Beitrag von MikeBatt » 21. Dez 2018 00:52

relativ einfach, zum einen weil ich erst danach den erwünschten Erfolg habe , zum anderen , weil es bei Boxen im Bootloop nötig ist. Ich habe meist Boxen gehabt , die im Bootloop sind, dabei habe ich gemerkt, das grade diese Geräte Probleme mit den Befehlen haben und man zB nicht abfragen kann, welche Partition aktiv ist. Jedoch kann man bei den Geräten in jedem Fall noch den Befehl abgeben welches die Startpartition sein soll. Ich habe mich hier auf NULL eingeschossen und das klappt wunderbar. Nehme ich jedoch eine Box ohne Bootloop und stelle diese nicht vorher auf Null wenn sie vorher auf EINS stand, dann bemerkte ich, das eben genau diese Boxen danach auch im Bootloop waren und erst der Wechsel auf NULL und ein erneutes schreiben führtn zum Erfolg.

Ich kann also keine wirkliche Antwort geben auf Deine Frage des Warum sondern einfach nur sagen, das ich genau so ständig Boxen fertig mache und auch wenn der Weg vlt nicht der 100% richtige ich, so habe ich aber immer zu 100% Erfolg. Vor allem weil ich direkt in MTD0/1 und MTD6/7 schreibe hat mich weiter gebracht, zu ANfang probierte ich es noch immer in 11/12 13/14 aber das führte häufig nicht zum Erfolg. Auch die Tatsache , das Branding erst nach dem Update zu entfernen hat Einfluß auf den Erfolg.

Wie gesagt ich mach das erst seit dem Frühjahr hatte bis zu diesem Zeitpunkt absolute keine Ahnung von dem Gerät und habe mir dann durch anlesen diverser Wege den Weg wie oben beschrieben für mich als den mit dem größten Erfolg gefunden.

Ignorieren kann ich den Befehl nicht, denn wenn ich es nicht so mache wie beschrieben dann klappt es eben nicht, ich brauche auch keine Konntrolle der Zertifikate , denn die Geräte die in den letzten 2 Jahren in Betrieb waren, haben alle new/new auch andere Infos aus dem Gerät benötige ich nicht, sämtliche Geräte die ich so hinbekommen habe, laufen im übrigen bei diversen Providern

Hinzugefügt nach 6 Minuten 55 Sekunden:
Auch was Du schreibst es spielt keine Rolle , das branding vorher oder nachher zu ändern kann ich nicht bestätigen , seit ich es am Ende ändere, habe ich keine Probleme .

Aber wie gesagt ich will hier keinem rein reden, sondern nur meine Erfahrungen wieder geben , die ich gemacht habe

Benutzeravatar
qwertz-asdfgh
Globaler Moderator
Globaler Moderator
Beiträge: 261
Registriert: 18. Okt 2017 21:47
Wohnort: Südliches T. d. A.
Hat sich bedankt: 4 Mal
Danksagung erhalten: 50 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#79 Beitrag von qwertz-asdfgh » 21. Dez 2018 16:58

MikeBatt hat geschrieben:
21. Dez 2018 00:58
relativ einfach, zum einen weil ich erst danach den erwünschten Erfolg habe , zum anderen , weil es bei Boxen im Bootloop nötig ist.
Beides kann ich nicht nachvollziehen. Da muss m.E. nach irgend etwas anderes schief gelaufen sein. Gleiches gilt für das Branding (auch hier kann ich nach wie vor deine Schilderung/Beschreibung nicht nachvollziehen).

Deine Schilderung (Boxen mit Bootloop bereits bekommen) deutet wohl auch darauf hin, dass da irgendetwas anderes nicht in Ordnung war (oder noch immer ist). Hier wäre es wohl hilfreich(er) gewesen (das mache ich übrigens sowieso immer bevor ich mit einer mir neuen/unbekannten Box irgendetwas anderes mache) das komplette Environment (und auch den Counter) per Bootloader auszulesen. Einerseits kann man dann u.U. bereits erkennen ob da schon was im argen ist oder bei Problemen im Nachhinein ein neues TFFS-Image erstellen (ggf. auch mit einem "korrigierten" Environment).

MikeBatt
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 22. Mai 2018 17:29
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#80 Beitrag von MikeBatt » 21. Dez 2018 17:21

Bei allem Respekt, es ist für mich am Ende nicht wichtig was Du nachvollziehen kannst und was nicht, es war mir sowieso klar, das mein Weg kritisiert wird.

Was den Bootloop an geht, so weiß ich woher er kommt muss mir daher nicht das ganze Environment anschauen, in den Bootloop gehen meist Geräte die vom Provider ein falsches Configfile bekommen haben oder ein falsches Update.

Im übrigen ist nach dem Flashen mit zB OS7.0 und einem erneuten Werksreste das Environment wieder genau so wie es sein muss.

Nochmals, ich möchte hier sicher kein Wissen schlecht reden, jedoch lasse ich mir meine Arbeit hier auch nicht schlecht reden, aber es war schon zur Zeit wo ich mich noch mit MOSC beschäftigt habe so, das es immer Leute gab, die das Tun von anderen angezweifelt haben , so ist es auch grade hier, ob Du nun gewisse DInge anzweifelst oder nicht, Fakt ist doch, das sämtliche Faqs die angeboten werden so erst mal nicht gehen, erst durch testen und probieren und dem Mischen diverser Anleitungen kam ich zu dem Erfolg den ich haben wollte und ganz ehrlich , all die laufenden Boxen und auch die Boxen die mittlerweile schon von 7.0 auf 7.01 gegangen sind , sagen für mich mehr aus, als das hier jemand irgend etwas anzweifelt , grade was das Enviroment angeht, ich habe es bei einer Box die och im Bootloop war ausgelesen und dann habe ich die Box einfach neu geflasht und erneut ausgelesen siehe da das Ergebnis war komplett anders, sämtliche Einträge, die nicht mehr gesetzt waren, standen danach wieder sauber im Gerät

Benutzeravatar
qwertz-asdfgh
Globaler Moderator
Globaler Moderator
Beiträge: 261
Registriert: 18. Okt 2017 21:47
Wohnort: Südliches T. d. A.
Hat sich bedankt: 4 Mal
Danksagung erhalten: 50 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#81 Beitrag von qwertz-asdfgh » 23. Dez 2018 02:58

MikeBatt hat geschrieben:
21. Dez 2018 17:21
Bei allem Respekt, es ist für mich am Ende nicht wichtig was Du nachvollziehen kannst und was nicht,
Für mich ist es dagegen ein Bedürfnis die Hintergründe zu verstehen und nicht irgendwelche "Mythen" als Erklärung zu akzeptieren.
MikeBatt hat geschrieben:
21. Dez 2018 17:21
es war mir sowieso klar, das mein Weg kritisiert wird.
Da missverstehst du offensichtlich was! Es geht hier nicht darum etwas (pauschal) zu kritisieren (zumindest wenn es sich nachvollziehbar erklären lässt) sondern ein bestimmtes (tw. nicht nachvollziehbares) Vorgehen zu hinterfragen (auch um u.U. existierende Missverständnisse auszuräumen). Und ebenfalls um zu verhindern, dass sich bestimmte Vorgehensweisen durchsetzen, ohne dass die Hintergründe dazu überhaupt erläutert wurden.

MikeBatt hat geschrieben:
21. Dez 2018 17:21
Was den Bootloop an geht, so weiß ich woher er kommt muss mir daher nicht das ganze Environment anschauen,
Das sichern (und u.U. auch anschauen) des Environment gehört (zumindest für mich) zu den ersten Schritten für eine Box die ich in die "Hände" bekomme, egal ob für diese tatsächlich notwendig oder nicht. Ich kann zwar verstehen, dass das für andere nicht dazugehört (ist auch nicht Bestandteil dieser Anleitung) aber bei den von dir beschriebenen Problemen würde ich es schon als eine Voraussetzung betrachten, ob dir das nun gefällt oder nicht.
Ich käme jedenfalls nicht auf die Idee (als Beispiel gedacht) bei solchen Problemen z.B. erst einmal mtd3+4 mit einer leeren Datei zu überschreiben (und somit im Zweifel noch mehr zu zerstören als vielleicht schon geschehen), soviel sei dazu gesagt, ein solches Vorgehen müsste man dann z.B. tatsächlich kritisieren (aka "schlecht reden" wenn man es denn so nennen möchte) bzw. sogar konkret davor warnen!

MikeBatt hat geschrieben:
21. Dez 2018 17:21
in den Bootloop gehen meist Geräte die vom Provider ein falsches Configfile bekommen haben oder ein falsches Update.
Wenn das tatsächlich die Ursache ist (zumindest beim Config-File) sollte m.E. bereits ein neues TFFS-Image helfen oder auch schon ein "141.xx.yy,recovered=n" (xx.yy = aktuelle Firmwarevers., n = 1|2|3) als Wert für die Variable firmware_info. Dann müsste man gar nicht erst ein anderes oder neues Firmware-Image über den Bootloader flashen. Aber ich glaube bis jetzt die Ursache für diese Probleme ist damit doch nicht eindeutig aufgedeckt/erklärt.

Denn bisher spricht das von dir beschriebene Verhalten tatsächlich eher für ein defektes Environment oder TFFS (und nicht nur für ein falsches Config-File) was durch bestimmte von dir durchgeführte Aktionen, vielleicht durch den Bootloader selbst oder von FritzOS, tw. wiederhergestellt wird/wurde (s.h. dazu auch folgender Beitrag: >klick<). Wenn du kein Interesse hast die Hintergründe für die Probleme zu eruieren dann kann ich das durchaus verstehen und auch damit leben aber andererseits werde ich dann auch das von dir beschriebene Vorgehen weiterhin in Frage stellen, so viel erlaube ich mir.

MikeBatt hat geschrieben:
21. Dez 2018 17:21
Fakt ist doch, das sämtliche Faqs die angeboten werden so erst mal nicht gehen,
Was vermutlich eher darin begründet ist, dass du vermutlich Anleitungen herangezogen hast, die sich nicht mit dem reparieren defekter Modelle beschäftigen sondern, so wie diese z.B., eher mit dem aufspielen einer Firmware per Bootloader und/oder dem De-Branding. Hier geht es in erster Linie also nicht darum defekte Boxen zu reparieren (auch wenn das, je nach Fehlerursache, tw. mit diesem Vorgehen möglich ist). Von daher könnte man dir dann vielleicht eher vorwerfen die falschen Anleitungung (aka Faqs) herangezogen zu haben.

Dass es sich in deinem Fall um "defekte" Modelle der 6490 handelte, die du mit deiner Methode "behandelst", hattest du in Beitrag #81 noch nicht erwähnt! Das wäre allerdings eine wichtige Information gewesen um die Methode vielleicht besser nachvollziehen zu können.


Auch die folgende Äusserung
MikeBatt hat geschrieben:
21. Dez 2018 00:58
... zum anderen , weil es bei Boxen im Bootloop nötig ist
kann ich so nicht teilen! Die Ursache für einen Bootloop kann sehr vielfältige Ursachen haben (von reinen Software/Config-Fehlern bis hin zu Hardwaredefekten). Dementsprechend kann man kaum feststellen, dass diese Methode bei (allen) Boxen im Bootloop nötig sei. Zumindest solange man die Ursache für den Bootloop nicht kennt.

Auch was folgendes betrifft
MikeBatt hat geschrieben:
20. Dez 2018 16:21
Niemals vor dem flashen das Branding verändern das mögen die Kisten nicht.
muss ich noch einmal klarstellen, bei "gesunden" Boxen spielt es keine Rolle ob man den Wert der Variable vor oder nach dem hochladen der Firmware ändert (zumindest bei den Modellen wo die Firmware direkt über den Bootloader in den Flashspeicher geschrieben wird, so wie es bei den Puma5/6-Modellen der Fall ist). Es fehlte also die durchaus wichtige Information, dass du dich auf defekte Boxen beziehst (mutmasslich defektes Environment). Diese Info kam eben leider erst auf Nachfragen bzgl. der Methode.

MikeBatt hat geschrieben:
21. Dez 2018 17:21
Im übrigen ist nach dem Flashen mit zB OS7.0 und einem erneuten Werksreste das Environment wieder genau so wie es sein muss.
MikeBatt hat geschrieben:
21. Dez 2018 17:21
... grade was das Enviroment angeht, ich habe es bei einer Box die och im Bootloop war ausgelesen und dann habe ich die Box einfach neu geflasht und erneut ausgelesen siehe da das Ergebnis war komplett anders, sämtliche Einträge, die nicht mehr gesetzt waren, standen danach wieder sauber im Gerät
Beides bestätigt eher meinen Verdacht, dass da von vornherein etwas nicht in Ordnung war (oder ist) mit dem Environment bzw. TFFS. Ich kann mir nicht vorstellen, das so etwas alleine durch ein falsches config-File oder Firmware-Update passierte. Und das musst du dir dann auch an Kritik gefallen lassen, dass du bei der Beschreibung deiner Herangehensweise ein paar relevante Informationen unerwähnt gelassen hattest.


Es kann durchaus sein, dass deine Methode bei Boxen mit defekten Environment/Config zum Erfolg führt (ich kann das weder bestätigen noch bestreiten), u.U. ist das auch von der Bootloaderversion abhängig (s.h. Link oben). Ich hatte auch schon Boxen mit einer fehlerhaften Config die ich mit dem aufspielen eines TFFS-Image wieder zum leben erweckt hatte und eines kann ich in diesem Zusammenhang nur noch einmal empfehlen, bei Boxen mit Problemen (Bootloop) als allererstes das komplette Environment (und Counter) zu sichern bevor man weitere Rettungs-Versuche unternimmt.

Bolemichel
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 2. Jan 2019 15:51
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#82 Beitrag von Bolemichel » 3. Jan 2019 14:58

Hallo,
ich hätte eine Bitte. Kann jemand die alten Firmware Versionen 6.60 oder 6.62 reuppen? Leider sind sie auf dem AVM Server nicht mehr verfügbar.
Danke!

MikeBatt
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 22. Mai 2018 17:29
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#83 Beitrag von MikeBatt » 4. Jan 2019 20:55

Irgendwie hast Du ja auf alles was ich Schreibe etwas negatives zu sagen , mir am Ende egal , denn ich weiß das ich richtig liege , denn bekomme mittlerweile schon Anfragen von den Anbietern direkt um die Geräte zu fixen. Aber wie ich sagte man sollte nicht immer zu Groß und zu kompliziert denken sondern einfach auch mal anderen Menschen Respekt zollen, aber das können einige leider nicht. Der gesamte Vorgang des Refresh dauert keine 3 Minuten und das Gerät ist wie neu und mittlerweile sind die schon im Dauereinsatz , haben erfolgreich das Update von 7.0 auf 7.01 geschafft. Was Du vlt nicht ganz verstehst , ich weiß das die Boxen in den Boot Loop gegangen sind wegen falscher config Files , ich vermute es nicht nur auch wenn Du es DIr nicht vorstellen kannst, aber dem ist so und Fakt ist auch, das nach einem Flash auf 7.0 oder 7.01 alles neu geschrieben wird und danach alles wieder stimmt, das war es für mich hier, denn die Akzeptanz ist mir hier einfach zu gering , ich danke nochmals allen für die Infos die ich bekommen habe , aber sowas wie hier grade muss ich nicht geben

Bolemichel
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 2. Jan 2019 15:51
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#84 Beitrag von Bolemichel » 5. Jan 2019 12:50

Kann bitte jemand die alten FW Versionen nochmal hochladen zum Download? Sie sind nicht mehr verfügbar bei AVM

Benutzeravatar
Micha0815
Fortgeschrittener
Fortgeschrittener
Beiträge: 31
Registriert: 22. Okt 2017 12:42
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#85 Beitrag von Micha0815 » 5. Jan 2019 14:53

Web-Archive schon probiert?
LG
Zuletzt geändert von Micha0815 am 5. Jan 2019 15:10, insgesamt 1-mal geändert.
Home 1:7390(OS 6.83)WAN via FB7490 (OS 6.90/6.88 modfs) im WLAN-Rep.-Modus AC 975/975MBit/s zu
Betreut Home1-Nachbar-Basis:FB7490 (OS 06.90/06.88modfs) 50/10K/1&1/FVD/
Home2: FB7490 (06.83/06.80modfs)ISP/Masmovil 0,5bis5 GB m.10.XX.er-IP (E3131 mit ext. Thiecom SLP15 ). Home2 verbunden via VPN zu Home1 mit allen SIP-Features -Dank "Käpsele"-
Betreut Div. FB7240 und 7490int in AT

Bolemichel
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 2. Jan 2019 15:51
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#86 Beitrag von Bolemichel » 5. Jan 2019 14:54

kurzer Zwischenstand meiner Experimente:

Ich habe noch eine alte KDG Box mit Ver 6.10 und habe es Dank der Anleitung in #1 nun erfolgreich debrandet und im zweiten Partitionset mit der Version 6.87 in Betrieb. Leider gibt es nur die aktuelle 7.01 und eben diese 6.87 bei AVM zum Download. Alle anderen Versionen sind nicht mehr bei AVM verfügbar. Aber nun konnte ich auch die certificates auslesen und die stehen leider wie vermutet auf old/old. Die Box war ja auch noch nie am Netz.

Ich wohne mittlerweile in BW und habe eine Connectbox von UM am Laufen. Könnte ich nun bei UM anrufen mit Angabe von MAC und Seriennummer und diese aktivieren lassen? Irgendwo hab ich gelesen, dass UM noch die alten Zertifikate akzeptiert und diese ggf. erneuert. Oder wird das nichts bringen?

Alternative: Ich könnte aber auch mal die FB per WLAN an die Connectbox hängen und erstmal versuchen Online die FB von 6.87 auf die aktuelle 7er zu aktualisieren. Evtl. werden dann die Zertifikate auch erneuert und ich könnte danach die FB aktivieren (nur so ein Gedanke).
Zuletzt geändert von Bolemichel am 5. Jan 2019 15:22, insgesamt 1-mal geändert.

Benutzeravatar
Micha0815
Fortgeschrittener
Fortgeschrittener
Beiträge: 31
Registriert: 22. Okt 2017 12:42
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#87 Beitrag von Micha0815 » 5. Jan 2019 15:17

Dies wird mutmasslich nix bringen, da 1tens der ominöse c4-Server von AVM down (der lieferte in DE-Kabelnetzen die neuen Zertifakte wohl einige Wochen? aus) und 2tens auch UM nur noch neue Certs akzeptiert.
LG und habe den Link #85 korrigiert, falls Du eine 6.63 in die alternative Partition aufspielen möchtest.
Zuletzt geändert von Micha0815 am 6. Jan 2019 11:07, insgesamt 1-mal geändert.
Home 1:7390(OS 6.83)WAN via FB7490 (OS 6.90/6.88 modfs) im WLAN-Rep.-Modus AC 975/975MBit/s zu
Betreut Home1-Nachbar-Basis:FB7490 (OS 06.90/06.88modfs) 50/10K/1&1/FVD/
Home2: FB7490 (06.83/06.80modfs)ISP/Masmovil 0,5bis5 GB m.10.XX.er-IP (E3131 mit ext. Thiecom SLP15 ). Home2 verbunden via VPN zu Home1 mit allen SIP-Features -Dank "Käpsele"-
Betreut Div. FB7240 und 7490int in AT

Bolemichel
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 2. Jan 2019 15:51
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#88 Beitrag von Bolemichel » 5. Jan 2019 15:24

Ja, vielen Dank! Das mit webarchive kannte ich noch nicht.

Mir kam nur eben der Gedanke mal die FB an die Connectbox zu hängen, die ja noch Internet hat und damit dann die FB zu aktualisieren. Also ganz normal über das Web Frontend der FB. Evtl. werden dann die Zertifikate erneuert!?

Benutzeravatar
Micha0815
Fortgeschrittener
Fortgeschrittener
Beiträge: 31
Registriert: 22. Okt 2017 12:42
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#89 Beitrag von Micha0815 » 5. Jan 2019 15:40

Du kannst es Versuchen, nur wäre es mehr als verwunderlich, wenn der c4-Server extra für Dich seitens AVM in Deinem Kabelsegment angeschaltet würde.
LG
Home 1:7390(OS 6.83)WAN via FB7490 (OS 6.90/6.88 modfs) im WLAN-Rep.-Modus AC 975/975MBit/s zu
Betreut Home1-Nachbar-Basis:FB7490 (OS 06.90/06.88modfs) 50/10K/1&1/FVD/
Home2: FB7490 (06.83/06.80modfs)ISP/Masmovil 0,5bis5 GB m.10.XX.er-IP (E3131 mit ext. Thiecom SLP15 ). Home2 verbunden via VPN zu Home1 mit allen SIP-Features -Dank "Käpsele"-
Betreut Div. FB7240 und 7490int in AT

Bolemichel
Einsteiger
Einsteiger
Beiträge: 5
Registriert: 2. Jan 2019 15:51
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#90 Beitrag von Bolemichel » 5. Jan 2019 15:48

ok Danke! Ich lasse die FB mal eine Weile an der Connectbox hängen und beobachte. Evtl. tut sich ja was. Das Update probiere ich dann morgen, hat ja noch Zeit.

reissaus73
Einsteiger
Einsteiger
Beiträge: 1
Registriert: 7. Jan 2019 15:28
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#91 Beitrag von reissaus73 » 7. Jan 2019 17:19

Super Anleitung
leicht vertändlich und sogar noch extra kommentiert
Einfach mal Top und ein fettes Lob an alle Mitwirkenden.

malaka
Einsteiger
Einsteiger
Beiträge: 2
Registriert: 8. Jan 2019 18:01
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#92 Beitrag von malaka » 8. Jan 2019 20:07

Also ich bin so ziemlich am verzweifeln mit meiner 6490 KDG box...

Es ist eine KDG 6490 gebrandete Fritzbox... Sie war schon mal im netz und hatte die Firmware 6.65 oder 6.85 drauf und etwas konfiguriert ( Feste IP )und die zertifikate ausgelesen und die waren new/new..

Das TuT von #1 hab ich gemacht... fs start war 0 am anfang

Im ersten lauf hab ich übersehen das man die KDG boxen nicht auf avm stellen kann... Gesagt getan und auf kdg umgestellt...

Firmware erneut drauf geflasht mittels ncftp...

Aber ich komme nicht mehr aufs WI drauf... Die box ist im bootloop... Komme aber per FTP drauf...

Wie kann ich die box wieder retten?? Will sie nur als AP nutzen.. Ach ja die Box blinkt nur 2 mal kurz bis sie dann bootloop bzw rebootet...

Benutzeravatar
qwertz-asdfgh
Globaler Moderator
Globaler Moderator
Beiträge: 261
Registriert: 18. Okt 2017 21:47
Wohnort: Südliches T. d. A.
Hat sich bedankt: 4 Mal
Danksagung erhalten: 50 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#93 Beitrag von qwertz-asdfgh » 9. Jan 2019 10:50

malaka hat geschrieben:
8. Jan 2019 20:07
Im ersten lauf hab ich übersehen das man die KDG boxen nicht auf avm stellen kann... Gesagt getan und auf kdg umgestellt...

Firmware erneut drauf geflasht mittels ncftp...
Also wenn man die Retail-Firmware darauf flasht muss man sie sogar auf "avm" stellen. Das nicht auf avm stellen gilt nur solange die KDG/Vodafone-Firmware darauf läuft. Wenn nun die Retail-Firmware darauf geflasht und gestartet wird muss sie also auf "avm" gestellt sein.

malaka
Einsteiger
Einsteiger
Beiträge: 2
Registriert: 8. Jan 2019 18:01
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#94 Beitrag von malaka » 9. Jan 2019 17:54

ok ich werde es mal probieren

Hinzugefügt nach 10 Minuten 19 Sekunden:
Das war es tatsächlich... Hab es hinbekommen... 7.01 drauf

danke viel mals

rawcat
Einsteiger
Einsteiger
Beiträge: 2
Registriert: 14. Jan 2019 11:25
Hat sich bedankt: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#95 Beitrag von rawcat » 14. Jan 2019 11:31

Hallo zusammen,

danke für die Anleitung. Ich habe eine gebrauchte Fritte gekauft und leider festgestellt, dass dort ein altes CM-Zertifikat drauf ist. Mit der jetzigen Firmware scheiterte leider die Einrichtung am Unitymedia-Anschluss.

Gibt es hier inzwischen einen Weg aktuelle Retail-Firmware zum Laufen zu kriegen?

Danke und Grüße

Benutzeravatar
Micha0815
Fortgeschrittener
Fortgeschrittener
Beiträge: 31
Registriert: 22. Okt 2017 12:42
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#96 Beitrag von Micha0815 » 14. Jan 2019 13:08

Falls die FB seinerzeit über den C4-Server an einem Kabelanschluss neue Certs erhielt, wurden diese sicherlich über ein Zurückstellen auf Werkseinstellungen leider ins Nirwana geschickt. Es wäre mehr als verwunderlich, falls ein Keinanzeigenverkäufer bei einer noch funktionierenden FB vor dem Verkauf nicht so verfahren wäre, wie es bei sonstigen DSL-FBs eigentlich üblich ist.
Eine 7.01-FW kann die neuen Zertifikate auchnicht herbeizaubern, sofern sie ebend nicht von Werk-aus im Bootloader stehen. Ab Seriennummer mit ~Fxxy (xx >35igste KW 2015) bekamen die FBs neue Certs in den Bootloader ab Werk.
Wer bei einer "gebrauchten" heutzutage auf certs old/old stösst hat in 99,x% der Fälle eigentlich keine Chance mehr auf eine Erneuerung der certs und somit auf die Provisonierungsmöglichkeit an einem Kabelanschluss von UM und KDG/VDF.
In 2ter Reihe hinter einem Kabelmodem oder als DVB-C-Tuner sind sie durchaus noch beliebt.
LG
Home 1:7390(OS 6.83)WAN via FB7490 (OS 6.90/6.88 modfs) im WLAN-Rep.-Modus AC 975/975MBit/s zu
Betreut Home1-Nachbar-Basis:FB7490 (OS 06.90/06.88modfs) 50/10K/1&1/FVD/
Home2: FB7490 (06.83/06.80modfs)ISP/Masmovil 0,5bis5 GB m.10.XX.er-IP (E3131 mit ext. Thiecom SLP15 ). Home2 verbunden via VPN zu Home1 mit allen SIP-Features -Dank "Käpsele"-
Betreut Div. FB7240 und 7490int in AT

rawcat
Einsteiger
Einsteiger
Beiträge: 2
Registriert: 14. Jan 2019 11:25
Hat sich bedankt: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#97 Beitrag von rawcat » 14. Jan 2019 13:52

Danke für dein Feedback. Sehr ärgerlich, besonders da ich beim UM-Support zuvor nachgefragt hatte ob die internationale Version laufen würde.
Scheinbar war der entsprechende Mitarbeiter von keiner Kenntnis getrübt und sagt, das sei kein Problem. :x

Naja, mal schauen ob ich die Kiste jetzt wieder losbekomme. (Seriennummer: F264… :naughty: )

Trojan
Einsteiger
Einsteiger
Beiträge: 2
Registriert: Gestern 00:25
Hat sich bedankt: 1 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#98 Beitrag von Trojan » Gestern 02:16

Hallo.
Ersteinmal: Vielen Dank für die ausführliche Anleitung.

Ich habe ein Problem: Ich komme nicht mehr per FTP auf die FB 6490. Sowohl mit dem FTP-Command (sagt Zeitüberschreitung) als auch mit dem EVA-Discover.ps1 (sagt EVA_IP="" FALSE)

Was habe ich gemacht:
Alles gesichert.
Zertifikate waren alle new/new
firmware_version kdg
linux_fs_start 0

Soweit so gut.
Dann habe ich die Environment-Variable auf "avm" gesetzt.
War auch alles top.
Danach wollte ich das Image mit dem EVA-FTP-Client flashen. Hat alles geklappt AUßER die Firmware lag in einem falschen Ordner (sie war nicht vertauscht!!!). Das heißt, dass Script konnte das Image nicht finden und ist abgebrochen. Hat also in Zeile 234 des Scripts "EVA-FTP-Client.ps1" eine Exception geworfen.

Jetzt komme ich nicht mehr per FTP auf die FritzBox. Sie ist denke ich im Bootloop, da der Power-Knopf blinkt, dann irgendwann lange aufleuchtet und dann aus geht.
Danach Blinken alle Lampen kurz auf (Boot) und die Powerlampe blinkt wieder.

Versuche währenddessen oder kurz nach dem Einstecken zum Strom auf den FTP Server zu verbinden sind alle gescheitert.


Wie kann ich wieder auf den FTP-Server verbinden??? Hilfe :O

//Nachtrag:

Ich hab jetzt so ziemlich alles probiert. Mit Linux FTP auf die Box zu verbinden, mit dem Powershell Script und mit ncftp.
Auch wird die Box nicht mehr unter ipconfig /all angezeigt.

Meine Vermutung ist:
Das Skript ist beim Flash abgebrochen und die FritzBox wurde neu gestartet. Durch das Skript wurde vorher aber noch die Commands: "TYPE I" (also der Transfermode auf BINARY gesetzt) und "MEDIA FLASH" gesendet. Dadurch ist es jetzt nicht mehr möglich per FTP auf die Box zu verbinden.
Zuletzt geändert von Trojan am 19. Jan 2019 10:04, insgesamt 1-mal geändert.

henrx
Einsteiger
Einsteiger
Beiträge: 1
Registriert: Gestern 01:53
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#99 Beitrag von henrx » Gestern 02:32

Hallo liebe Community,

ich habe ein Kabelanschluss von Vodafone mit einer geliehenen Fritzbox Cable 6490.
Nun fand ich auf Kleinanzeigen in meiner Nähe eine Fritzbox für 60€ mit kdg Branding und FritzOs 6.65 (weiteres noch nicht ausgelesen).

Im Vorfeld hatte ich natürlich gegoogelt nach einer Anleitung zum debranden und wurde auch schnell fündig.
Also gekauft, Branding entfernt, und siehe da es funktioniert nicht. Die Anleitung fand ich auf Chip und ist diese typische adam-Anleitung.

Ich habe dann weiter gesucht und diese Anleitung hier gefunden.
Und nun zu meiner Frage:

Angenommen ich entferne das Branding, lade neue firmware rauf usw., befolge die Anleitung komplett wie es beschrieben ist und alles läuft erfolgreich ab, kann ich die Box dann als Ersatz für die geliehene Box verwende? (Das ist eigentlich die Idee dahinter)

Beziehungsweise, ist es irgendwie möglich die Fritzbox so hinzubekommen, dass sie wie eine ungebrandete neue Fritzbox ist?

Ich frage weil ich mir nicht die Mühe machen will wenn es sowieso nie gehen wird.

Sollte es gehen, dann habe ich richtig lust mich in die Thematik einzuarbeiten.
Zu meiner Erfahrung, ich habe schon öfter mit Linux und Shell bzw. Eingabeaufforderungen gearbeitet.


Danke und beste Grüße

Benutzeravatar
qwertz-asdfgh
Globaler Moderator
Globaler Moderator
Beiträge: 261
Registriert: 18. Okt 2017 21:47
Wohnort: Südliches T. d. A.
Hat sich bedankt: 4 Mal
Danksagung erhalten: 50 Mal
Status: Offline

[HowTo] Ändern des Branding und installieren der Retail-Firmware bei FRITZ!Box Cable 6490

#100 Beitrag von qwertz-asdfgh » Gestern 13:16

@Trojan
Das von dir beschriebene erklärt nicht, dass nun der Bootloader nicht mehr erreichbar sein soll. Versuche ob das Recovery-Tool einer anderen Box von AVM die Box findet. Ansonsten vielleicht folgende Anleitung:
https://www.ip-phone-forum.de/threads/299790/




henrx hat geschrieben:
Gestern 02:32
Angenommen ich entferne das Branding, lade neue firmware rauf usw., befolge die Anleitung komplett wie es beschrieben ist und alles läuft erfolgreich ab, kann ich die Box dann als Ersatz für die geliehene Box verwende?
Wie schon in Beitrag #7 unter "Voraussetzungen und Hinweise" steht:
qwertz-asdfgh hat geschrieben:
26. Okt 2017 03:14
Folgende Hinweise sind zu beachten wenn man anschließend die Retail-Firmware flashen möchte (4. Schritt, s.h. Beitrag #12):
  • Die 6490 darf bzw. kann nach dem De-Branding mit der Retail-Firmware eventuell/höchstwahrscheinlich nicht mehr an einem Anschluss des Kabelnetzbetreiber betrieben werden von dem die FRITZ!Box ursprünglich stammt (s.h. auch Vorwort).
    Beispiele:
    • Eine HomeBox 3 (6490) von KDG/Vodafone kann anschließend nicht mehr an einem KDG/Vodafone Kabel-Anschluss als Kabel-Modem/Router betrieben werden (weder am eigenen noch an anderen)! Allerdings kann sie anschließend z.B. an einem Unitymedia- oder PŸUR-Anschluss betrieben werden.
    • Eine 6490 vom Anbieter Unitymedia kann anschließend nicht mehr an einem Unitymedia-Anschluss betrieben werden (weder am eigenen noch an anderen)! Allerdings z.B. an einem Vodafone-Kabel oder PŸUR-Anschluss
    Für einem Unitymedia-Anschluss sollte man also zum Beispiel eine 6490 vom Anbieter KDG/Vodafone verwenden (oder eine Wilhelm.tel-Edition oder auch die internationale Variante) bzw. vice versa. Oder natürlich eine freie aus dem Handel mit der Artikel-Nr. 2000 2778. Für die entsprechenden Artikel-Nr. s.h. Beitrag #3
  • ...
Oder kurz:
Eine ehm. KDG/Vodafone-Box (egal ob ge- oder entbradet) kann nicht an einem anderen Kabel-Anschluss von KDG/Vodafone weiter betrieben werden.

Antworten

Zurück zu „FRITZ!Box Modifikationen“